SSL Problems.. Solved.. but WHY?

Post By:user_47945 | Reply

Well I figured out why I was getting the Red Padlock like the other 15 posts on here.. Everyone was having pretty much same issue I had.. Go to login and get a half encrypted page, go to checkout half encrypted, annoying popup warnings.. So I went through the code and it ended up being that Google Analytics code that is put in.. I don't use it so I haven't a clue whos account is getting my monitoring. However this raises a question.. What if someone has an Analytics account and wants to monitor? Anytime that code is put in and you go to an SSL site, it will be half encrypted..

Any ideas? Grant it the script is calling http:// instead of https:// but I dunno.. It works now, I got solid SSL encrypted page Yellow bar and all :)
user_47945Sun, 24 Feb 2008

Ok I got my SSL working so it showed yellow bar and lock.. Instead of telling me it was half encrypted.. The problem was the Google Analytics code at the bottom.. Once removed the page went encrypted.. Only SSL occurs at login and checkout..

However new problem.. When your in the login page or shopping cart checkout, all my links are SSL now.. Like Home etc.. How can I make them http? Only one that went http under SSL was my product category..

http://www.dieselstormtrucks.com

If you want to see.. Just hit the login page and then look at my top link header images, the Company/Resources box and the bottom links.. Everything is in https:// and not http://

`Reply Or Comment!
Please LogIn to Reply!